Vulnerability in Exim mail server opens full access to the server

Monday, June 10, 2019


If you are using Exim mail server version below 4.92 - update immediately. Starting from version 4.87 to 4.91 inclusive, the mail server contains an error in the code, which can be used by attackers to get root-access to the server. This is an extremely dangerous situation. How to upgrade? In order to upgrade, you need to connect to the server via  SSH  as a user with root...

More »



New AMD Opteron prices

Wednesday, April 24, 2019


Hello! We are glad to inform you that prices of all our AMD Opteron dedicated servers have decreased by $5. The new prices are: AMD Opteron 3280 Octo-Core 2.4 GHz #1 - $33/mo. AMD Opteron 3280 Octo-Core 2.4 GHz #2 - $33/mo. AMD Opteron 3280 Octo-Core 2.4 GHz #3 HDD - $40/mo. AMD Opteron 3280 Octo-Core 2.4 GHz #3 SSD - $45/mo. AMD Opteron 3280 Octo-Core 2.4 GHz #4...

More »



Security update

Thursday, February 7, 2019


Dear Customers! For security reasons we have added 2 factor authorization. You can enable it in the Client Area



Yandex.Money

Tuesday, June 13, 2017


Dear Customers! We have added a new payement gateway - Yandex.Money



Big Sale

Wednesday, May 10, 2017


Dear customers! We glad to inform you, that we have started a big sale for server family Intel Core i7-6700K Quad-Core 4,2 GHz. All offers you can find in our Special offers



Announcement of Planned Network Maintenance

Friday, February 10, 2017


Dear customers. In order to provide continued high value service to our customers, we require updating the switches in our DC in Saint-Louis, USA. During that time servers may be temporarily unreachable for a very short time. The proactive network maintenance will occur on: February 14, 2017, between the hours 9:00 AM and 13:00 PM CET/ 2:00 AM and 1 PM CT. We apologize for any...

More »



Happy New Year!

Monday, January 2, 2017


Happy New Year!



PHP 7 support

Monday, September 19, 2016


Dear Clients! Now available ability to use PHP 7 on our hosting servers. Based on the results of various tests using PHP 7 achieved a significant increase in the speed of the web site. If your site uses a CMS WordPress or Joomla, we advise you to choose the PHP 7 (some add-ons may not be compatible!). You can enable PHP 7 in the Hosting Control Panel in the section " Domain Management" -...

More »



New DC in the Netherlands

Monday, July 11, 2016


Dear Customers! We glad to inform you that we have a new DC in the Netherlands. Now we offer good servers with good price



Monitoring system

Wednesday, October 7, 2015


Dear Customers! We are glad to inform you that we have started a new monitoring system. Now you will be informed about status of your server! We give you first month for free. Just apply promo-code MONITORINGFREE in the shopping cart.




« Prev Page
Next Page »
Language: